Quantcast
Channel: Nginx Forum - Php-fpm Mailing List - English
Browsing index pages (219 articles)
↧

NGINX Error - recv() failed (104: Connection reset by peer) while reading...

Hi, Getting following error on NGINX error logs. ANy help would be appreciated. NGINX Error Logs: 9721 recv() failed (104: Connection reset by peer) while reading response header from upstream, client:...

View Article


NGINX FPM upgrade (no replies)

I am trying to upgrade roundcube from 1.4 (working) to 1.6.2. I am aware that I need to upgrade my PHP version before I upgrade. Raspberry OS – Buster NGINX chew@mail:~ $ php -v PHP 7.3.31-1~deb10u4...

View Article


How to set root absolute include path in a php-fpm + nginx? (no replies)

I have the following files structure: var #################################### └── www ############################## #####└── html ########################## ########## ├── include ##################...

View Article

Why php8.2 permission denied?? (no replies)

I am facing issues on my website. When i post thai lottery result on my website then go to php then same issue appeared that php8.2 permission denied. Please help if anyone know about this

View Article

php8.2-fpm permission denied (no replies)

I have upgraded an existing php-fpm 7.4 installation to 8.2. I don't have problems using 7.4 I am using www-data as user in both nginx and php8.2.fpm I am using socket connection between services I am...

View Article


Nginx and PHP-FastCGI Process Manager (no replies)

Hi, I am using nginx web server and php-fpm backend service to process all php files. NGINX proxies web requests and passes them on to PHP-FPM worker processes that execute the PHP application. Is...

View Article

php-fpm long delay before returning output (no replies)

Hello, The problem I'm experiencing: randomly, some requests take an extra 20 seconds, up to 60s to finish. Manually running curl shows the following behavior: - curl example.com/api - 2 seconds -...

View Article

Browser downloads php pages (1 reply)

Hi, As I explained everything here : https://serverfault.com/questions/1077642/browser-downloads-the-file-instead-of-opening-php-files my main problem is that : either the php page I try to access from...

View Article


Wordpress url prefix nginx Subdomain / Subfolder (no replies)

Hi I'm runing Nginx in Webmi/Virtualmin server I read more about configuration for URL Prefix and Now I'm confusing ... Would you please read? 1-What is different between these to lines? I copied the...

View Article


PHP Configuration with nginx (1 reply)

Hello everyone, I try to configure PHP with an nginx server (with this instruction https://www.cyberciti.biz/faq/how-to-install-php-on-opensuse-15-2-15-1/ ), but get 404 NOT FOUND when try URL...

View Article

How to properly set fastcgi_param SCRIPT_FILENAME - nothing seems to work (1...

Sorry for this noob question, but frustration is eating me. I'm trying to set up my php app for 2 straight days, and no config seems to work to load it properly. My config: server { server_name...

View Article

Getting 400 Bad Request on .js.php Files (no replies)

Hello Group, we have a website running with an upload for media files. When i want to upload media then the following error is sent back to the browser: upload:524 GET...

View Article

nginx image filter: image gets rotated instead of crop (no replies)

Hello, I have an old and proven to work config like this (like, literally, for dozen of years): server { listen 8085 default; listen [::]:8085 default; root /usr/local/public/storage; location ~...

View Article


nginx, grpc and client body buffering (no replies)

Hello, Seems like when using grpc on nginx 1.16.x the client body is _always_ buffered on the disk. Yeah, seems absolutely weird, but: 1) here's the $request_lengths (not $body_bytes_sent), top 25...

View Article

Error 502 Bad Gateway on nginx and php-fpm (no replies)

I can't start php7-fpm in supervisor. The error log: unable to bind listening socket for address '127.0.0.1:9000': Address in > use (98) In browser: localhost:8090 is error: 502 Bad Gateway netstat...

View Article


PHP fpm config with WP site (2 replies)

Hi Everyone, I have a wordpress site running with following configuration: Server Memory: 32G VCPUs: 8 Daily visitors: About 4000 Visitors/day Mysql Server (Separate) Memory: 15G VCPUs: 4 pm = dynamic...

View Article

PHP5-FPM 502 Bad Gateway error on virtual host (1 reply)

I have an iRedMail installation running php5-fpm and i setup a second website using virtual host. The website it self works but i cant get php on the virtual host, it gives me a 502 error every time....

View Article


413 Request Entity Too Large (no replies)

Hi, I have set the below settings. /etc/php.ini max_input_time = 60 max_execution_time = 200 upload_max_size = 100M upload_max_filesize = 100M post_max_size = 100M /opt/nginx/conf/nginx.conf...

View Article

how to intercept upload file error? (no replies)

Hi, I'm using nginx and a fastcgi service to upload some audio-video contents. This is my conf: location /catramms/binary { if ($request_method = POST) { rewrite ^/catramms/binary/([0-9]+)/?$...

View Article

How should I create an alias outside the root directory in nginx? (1 reply)

Hi, I am trying to create a protected directory that is outside the documents in the root directory. I tried to place an alias to a directory external to the root directory of the server, but I am...

View Article
Browsing index pages (219 articles)


Latest Images